Jump to content
The Classic Speaker Pages Discussion Forums
klhhead

KLH Model 20 Bass rattle

Recommended Posts

I have a pair of restored model 20s that are fantastic but unfortunately one of them has developed a rattle when playing low frequencies at high volume. The speaker doesn't sound blown, but its almost as if something has fallen out of place and is vibrating against the cone. At lower volumes the sound disappears. Pulling off the grid there is no visible damage and the foam looks to be in good shape. Any ideas, advice, or suggestions would be very much appreciated. I don't really want to open this baby up until I know what I am planning to do.

Cheers

Share this post


Link to post
Share on other sites
3 hours ago, RickB said:

Try rotating the woofer. Sometimes the spider gets loose. That does happen by it also be loose so replying it may be the fix.

I hadn't thought about rotating it, I might give that a try before resorting to replacing the whole thing

Share this post


Link to post
Share on other sites

Welcome klhhead

You can also Google "re-gluing loose speaker spider" but you can probably pick up a used Twenty woofer for under 20 bucks. Just be sure it's a 20 and not a 17. As you know, the 20 is 4 ohms.

Kent

Share this post


Link to post
Share on other sites
1 hour ago, JKent said:

Welcome klhhead

You can also Google "re-gluing loose speaker spider" but you can probably pick up a used Twenty woofer for under 20 bucks. Just be sure it's a 20 and not a 17. As you know, the 20 is 4 ohms.

Kent

Thanks Kent! I already started looking around for one

Share this post


Link to post
Share on other sites
On 12/9/2019 at 1:32 AM, klhhead said:

I have a pair of restored model 20s that are fantastic but unfortunately one of them has developed a rattle when playing low frequencies at high volume. The speaker doesn't sound blown, but its almost as if something has fallen out of place and is vibrating against the cone. At lower volumes the sound disappears. Pulling off the grid there is no visible damage and the foam looks to be in good shape. Any ideas, advice, or suggestions would be very much appreciated. I don't really want to open this baby up until I know what I am planning to do.

Cheers

I had the same problem with a different model, but worth considering.

Low frequency rattle driving me crazy.

Turned out to be the crossover (glued to the cab. Interior) had come away an was flapping away inside, causing the noise.

 

Bill

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...