Jump to content

Powered Advent Loudspeaker (PAL) - Missing woofer


charlie2951
 Share

Recommended Posts

Hi Everyone, 

I bought these PALs in December from the original owner. I just noticed that one is missing a woofer. I don't want to get involved in sourcing replacements, and I'd like to just sell them. I'm a big Advent fan, and I'd really prefer for them to fall to someone who appreciates them and can fix them up, so I'm listing them here.

I turned them on very briefly, for about 10 seconds each. The green light comes on, you can hear both amps humming gently, then they click (similar the sound my receiver makes when the input is engaged), then light static comes from the tweeters.

$100 takes them. I'm located just outside of NYC. A few pictures are below, but the google photos link has a total of 22.

Best,

Charlie

 

 

https://photos.app.goo.gl/CjChSFzHbKS4qHn72

20180430_184855.jpg

20180430_184939.jpg

20180430_185034.jpg

20180430_185113.jpg

20180430_185222.jpg

20180430_185655.jpg

20180430_191641.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...