Jump to content
The Classic Speaker Pages Discussion Forums

RudeMechanical

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About RudeMechanical

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Well, Roy, you may have hit the nail right on the head with the idea about the yellow wires. I twistes the wire nut off and this is what I found: Under the wire nut Its a bit blurry, but two of the wires are securely connected, but the third is pretty loose in there. I think I'm going to get rid of the wire nut entirely and go with a solder joint instead. I am going to re-cap it, since its already open and those originals are pretty old. I'm thinking of going with the Dayton MPPs (5%) in the following values: 75 mf (to replace the 72 mf) 2 x 12 mf ( for the 24 mf) 4 mf. Should that be ok, or should I go for exactly 72 mf? Percentage- wise it's not that far off the target, but its not dead on either.
  2. I will definitely try that. I'm keeping my fingers crossed that is the problem because, as you say, the tweeter and mid wouldn't naturally go out at the same time. I'll probably go ahead and re-cap the thing while I have it open--it will save me the trouble of opening it up again sometime in the future.
  3. Crossover pic 1 Crossover pic 2 Crossover pic 3 Crossover pic 4
  4. Ok--its not letting me upload pictures, so I'll have to figure a workaround.
  5. Ok, I opened the speaker up and dug out all the stuffing. I didn't find anything that looked obviously loose or disconnected. The one thing that looked the most out of place was the the big wax block capacitor. It had slid down in its brackets and was sitting on the bottom of the cabinet. A piece of wax was broken loose from the spot where the wires go into the box and one wire was a little wiggly. I checked all the wire nuts (I hate wire nuts) and they seemed secure. The jumper between the speaker wire posts is also present and securely connected. So I don't know where to go next. I also checked the woofer and I don't believe there is any voice coil rub or any other trouble there. It seems to me that the only place left for the problem is in the crossover. Anyway, here are a few photos of what I found inside. Maybe something will jump out at someone else.
  6. Thanks. I'll have to check it out this weekend. It would take a while to get the parts list together and ordered anyway. I'd be thrilled if I can get the speaker working again with a cheap fix. ?
  7. Well, I did the battery test on the speakers and they all responded. I also did the "toilet paper roll to the ear" trick and the mid and hi speakers are making some very low level of sound. I haven't found my multimeter yet after my recent move, so I didn't resistance test them. Still I think the speakers themselves are functioning. So I'm guessing that the problem is with the internals. Is the next step replacing all the caps? Should I rewire the whole thing while I am at it?
  8. Thanks. I'll have to try one (or more) of those tests tomorrow and see what I find.
  9. Hi folks, I hope you can give me a little guidance with a speaker problem I'm having. I bought a pair of AR5 speakers back in '07 or so and they have been nothing but great. When I got them, they had been reformed and the pots replaced with L-pads. Tonight, I noticed that all of the sound was coming from one speaker. I isolated the problem speaker and found that the sound level was very low and very muffled. It seemed like the only working speaker is the woofer. After switching the leads, I determined that the problem was the speaker and not my amp. Adjusting the pots on the speaker did not make any noticible difference to the sound, but did not produce any crackles or pops. So I love the speakers, and want to fix them, but I don't know where to start. Could the problem be bad caps in the crossover? Or is it more likely that the tweeter and mid have gone bad? How would I even know? Thank you for any help you can give me.
×
×
  • Create New...